Internal connectivity issues
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 17, 2016 - 06:17 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. Aug 17, 2016 - 05:50 PDT
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Aug 17, 2016 - 05:43 PDT