Authentication problems
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 09, 2017 - 17:22 PST
Investigating
We are identifying a problem with our authentication servers.
Posted almost 2 years ago. Feb 09, 2017 - 17:08 PST