Webhook Delays
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 11, 2019 - 09:15 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Feb 11, 2019 - 08:47 PST