Seeing a high ratio of 202s to 200s on the Person API
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 18, 2016 - 10:15 PST
Investigating
We are currently investigating this issue.
Posted 10 months ago. Nov 18, 2016 - 07:59 PST