Person and Company Audience Results are Delayed
Incident Report for Clearbit
Resolved
Company and Person Audiences are returning results as expected for both new and updated audiences.
Posted Nov 25, 2024 - 08:48 PST
Identified
We have identified the cause of the delay in returning results for new and updated Person and Company Audiences. The issue is due to a higher-than-usual volume in our processing queue. Our team is working to address this and will continue to monitor progress closely. We appreciate your patience as we work toward resolution.
Posted Nov 22, 2024 - 14:26 PST
Investigating
New and updated Person and Company Audiences are experiencing delays in returning results. Our team is actively investigating the cause of the issue.
Posted Nov 22, 2024 - 14:07 PST
This incident affected: Dashboard.