Person queues backed up. Spinning up more workers to handle the load.
Incident Report for Clearbit
Resolved
Additional workers drained the queues. System back to normal now.
Posted about 2 years ago. Apr 26, 2016 - 09:13 PDT
Investigating
We are currently investigating this issue.
Posted about 2 years ago. Apr 26, 2016 - 09:01 PDT