Degraded performance for Clearbit Platform UI
Incident Report for Clearbit
Resolved
This issue is now resolved.
Posted Feb 06, 2024 - 16:15 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 05, 2024 - 09:09 PST
This incident affected: Clearbit Data Activation Platform (Platform UI).