Batch enrichment processing delays

Incident Report for Clearbit

Resolved

This incident has been resolved.
Posted Dec 22, 2025 - 01:50 PST

Monitoring

All delayed batches have been processed. We're monitoring the service.
Posted Dec 18, 2025 - 00:30 PST

Identified

We're working on a fix for enrichment batch processing. Jobs are still delayed.
Posted Dec 17, 2025 - 16:53 PST

Investigating

We're currently investigating delayed batch enrichment processing.
Posted Dec 17, 2025 - 07:17 PST
This incident affected: Batch.