We will be undergoing scheduled maintenance during this time.
Posted Oct 22, 2025 - 11:29 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 22, 2025 - 11:28 PDT
Scheduled
Hi there,
As part of our previously announced plans to sunset the Clearbit Logo API, we will be conducting scheduled maintenance on November 12, 2025, during which the Logo API will be intentionally disabled for 24 hours.
This temporary disruption is intended to help remaining users become aware of the upcoming sunset and to encourage a timely transition to an alternative solution.
What to Expect During the maintenance window: - Requests to logo.clearbit.com will return an error. - No logo assets will be served from calls made to logo.clearbit.com during this period.
Why This Is Happening Clearbit announced in March 2025 that the free Logo API will be fully discontinued on December 8, 2025. Despite ongoing communications, usage remains high. This planned brownout is a proactive step to ensure developers notice the deprecation before service ends permanently.