Authentication outage
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted over 1 year ago. May 24, 2016 - 04:35 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. May 24, 2016 - 04:19 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. May 24, 2016 - 04:10 PDT