Person queues backed up
Incident Report for Clearbit
Resolved
Issue resolved! We're taking some steps to making sure this doesn't happen again.
Posted about 2 years ago. Jun 02, 2016 - 10:27 PDT
Investigating
We are currently investigating this issue.
Posted about 2 years ago. Jun 02, 2016 - 09:55 PDT