Increased Error Rate
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted 24 days ago. Sep 21, 2018 - 19:01 PDT
Monitoring
The issue has been identified and a fix is being implemented.
Posted 24 days ago. Sep 21, 2018 - 18:45 PDT
This incident affected: Connect.