Clearbit X - Delayed Form and Event processing
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 18:51 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2020 - 13:16 PST
Identified
We've identified an issue with database load and are working to resolve.
Posted Feb 07, 2020 - 11:23 PST
This incident affected: Clearbit X (API, Forms).