Google Ads Destination Delivery Delays
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 12:10 PST
Monitoring
We've fixed the issue and are now monitoring.
Posted Feb 16, 2024 - 16:53 PST
Identified
We are experiencing an issue with destination deliveries for Google Ads. Customers will experience delays in synchronizing Audiences to their Google Ads account. The problem has been identified and we are working on a fix.
Posted Feb 16, 2024 - 11:12 PST
This incident affected: Clearbit Data Activation Platform (Platform UI).