Delayed Clearbit X Form and Event processing
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted Feb 06, 2020 - 21:27 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2020 - 20:46 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2020 - 15:02 PST
This incident affected: Clearbit X (API, Forms).