Intermittent issues
Incident Report for Clearbit
Resolved
This incident has been resolved.
Posted almost 2 years ago. Aug 16, 2016 - 09:55 PDT
Investigating
We are experiencing intermittent connectivity issues and are investigating now.
Posted almost 2 years ago. Aug 16, 2016 - 09:10 PDT